Debian apt-get update ошибка There are no public key available for the following key IDs

При попытке выполнить apt-get update в конце появляется сообщение

There are no public key available for the following key IDs :
4D270D06F42584E6
W: You may want to run apt-get update to correct these problems


Если при установке nginx случайно забыли внести ключ (см документацию) - возможна похожая ситуация. Выполняем тот самый шаг в соответствии с документацией Nginx.

Для Debian есть

apt-key update
Возможно потребуется информация о ключах предыдущих версий:
apt-get install debian-archive-keyring
apt-key update

Ну и крайний случай - поиск ключа “вручную” (keyserver можно не указывать)
# gpg --recv-keys XXXXXXXXXXXXXXXX
# gpg --keyserver wwwkeys.eu.pgp.net --recv-keys XXXXXXXXXXXXXXXX
apt-key add /root/.gnupg/pubring.gpg
apt-get update

Если ключ был сохранён (gpg не выдал ошибки), добавляем его (apt-key add)
После этого выполнение команды не вызовет ошибку no public key available
apt-get update

И да, по аналогии с установкой debian на php 5.2 на Debian Squeeze можно пользоваться предыдущей версией дистрибутива с сайта http://snapshot.debian.org/

Метки:

Автор будет признателен, если Вы поделитесь ссылкой на статью, которая Вам помогла:
BB-код (для вставки на форум)

html-код (для вставки в ЖЖ, WP, blogger и на страницы сайта)

ссылка (для отправки по почте)

Добавить комментарий